summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorTim-Philipp Müller <tim@centricular.com>2020-07-04 12:10:23 +0100
committerTim-Philipp Müller <tim@centricular.com>2020-07-04 15:05:23 +0100
commit7b2c3a984c75156d4d3f1029016ff66307c71b2b (patch)
treeaf6018c5d9ef13044eeae1b7219cf48a46b6546d /meson.build
parent31d5d04bb1f5e3f6acdef8460193019237ecf5df (diff)
downloadgstreamer-plugins-bad-7b2c3a984c75156d4d3f1029016ff66307c71b2b.tar.gz
meson: add update-orc-dist target
Add target to update backup orc -dist.[ch] files. Part-of: <https://gitlab.freedesktop.org/gstreamer/gst-plugins-bad/-/merge_requests/1408>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build24
1 files changed, 24 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 3d2087011..4c2649a14 100644
--- a/meson.build
+++ b/meson.build
@@ -373,6 +373,7 @@ have_objcpp = add_languages('objcpp', native: false, required: false)
have_orcc = false
orcc_args = []
+orc_targets = []
# Used by various libraries/elements that use Orc code
orc_dep = dependency('orc-0.4', version : orc_req, required : get_option('orc'),
fallback : ['orc', 'orc_dep'])
@@ -446,6 +447,29 @@ subdir('data')
subdir('tools')
subdir('pkgconfig')
+if have_orcc
+ update_orc_dist_files = find_program('scripts/update-orc-dist-files.py')
+
+ orc_update_targets = []
+ foreach t : orc_targets
+ orc_name = t.get('name')
+ orc_file = t.get('orc-source')
+ header = t.get('header')
+ source = t.get('source')
+ # alias_target() only works with build targets, so can't use run_target() here
+ orc_update_targets += [
+ custom_target('update-orc-@0@'.format(orc_name),
+ input: [header, source],
+ command: [update_orc_dist_files, orc_file, header, source],
+ output: ['@0@-dist.c'.format(orc_name)]) # not entirely true
+ ]
+ endforeach
+
+ if meson.version().version_compare('>= 0.52')
+ update_orc_dist_target = alias_target('update-orc-dist', orc_update_targets)
+ endif
+endif
+
# xgettext is optional (on Windows for instance)
if find_program('xgettext', required : get_option('nls')).found()
cdata.set('ENABLE_NLS', 1)