summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorTim-Philipp Müller <tim@centricular.com>2019-10-18 00:39:12 +0100
committerTim-Philipp Müller <tim@centricular.com>2019-10-18 00:39:12 +0100
commit97a4d0cd7de8cfbf983acc7e37ba2f8fb73c3e19 (patch)
tree3722d3b9629f64f9c271e94e14355f64f48ccfb3 /meson.build
parenta40476914d4cbc944b56d919538afa751fc3d813 (diff)
downloadgstreamer-plugins-bad-97a4d0cd7de8cfbf983acc7e37ba2f8fb73c3e19.tar.gz
meson: build gir even when cross-compiling if introspection was enabled explicitly
This can be made to work in certain circumstances when cross-compiling, so default to not building g-i stuff when cross-compiling, but allow it if introspection was enabled explicitly via -Dintrospection=enabled. See gstreamer/gstreamer#454 and gstreamer/gstreamer#381.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 67aeeb4d0..7b3314bd9 100644
--- a/meson.build
+++ b/meson.build
@@ -411,7 +411,7 @@ python3 = import('python').find_installation()
gir = find_program('g-ir-scanner', required : get_option('introspection'))
gnome = import('gnome')
-build_gir = gir.found() and not meson.is_cross_build()
+build_gir = gir.found() and (not meson.is_cross_build() or get_option('introspection').enabled())
gir_init_section = [ '--add-init-section=extern void gst_init(gint*,gchar**);' + \
'g_setenv("GST_REGISTRY_1.0", "@0@", TRUE);'.format(meson.current_build_dir() + '/gir_empty_registry.reg') + \
'g_setenv("GST_PLUGIN_PATH_1_0", "", TRUE);' + \