summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorXavier Claessens <xavier.claessens@collabora.com>2020-04-08 12:10:21 -0400
committerGStreamer Merge Bot <gitlab-merge-bot@gstreamer-foundation.org>2020-04-08 18:51:12 +0000
commitb462870094df2063e88dcf827667c6338112ddc9 (patch)
treea8171a404063eb3d40a2d4d47f073e7acb0b82f0 /meson.build
parenteea520fe6dfef77f5917f18e0ea0bbfd4c477b1a (diff)
downloadgstreamer-plugins-bad-b462870094df2063e88dcf827667c6338112ddc9.tar.gz
Meson: Change extra-checks to feature option and make it yielding
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 5f992891b..fced76540 100644
--- a/meson.build
+++ b/meson.build
@@ -385,7 +385,7 @@ else
message('Orc Compiler not found or disabled, will use backup C code')
cdata.set('DISABLE_ORC', 1)
endif
-cdata.set('GST_ENABLE_EXTRA_CHECKS', get_option('extra-checks'))
+cdata.set('GST_ENABLE_EXTRA_CHECKS', not get_option('extra-checks').disabled())
gnustl_dep = declare_dependency()
if host_system == 'android'