summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorJan Schmidt <jan@centricular.com>2019-09-06 19:13:46 +1000
committerJan Schmidt <thaytan@noraisin.net>2019-11-12 13:00:42 +0000
commitc0561fb916780ec2fdfafe09e31a74ff5fa5ec08 (patch)
tree975ea32d2833cd8a509450eb110a80e1b3331a65 /meson.build
parent346bca80af4c00e126dc51eb20653cb3697f51fd (diff)
downloadgstreamer-plugins-bad-c0561fb916780ec2fdfafe09e31a74ff5fa5ec08.tar.gz
meson: Fix plugin symbol export for C++ sources/plugins
The symbol visibility=hidden flag was only being applied to C compilation, so plugins implemented in C++ would leak extra symbols than the 2 _get_desc() and _register(). That also showed that the gst-libs opencv C++ lib was not marking symbols for export correctly because the BUILDING_GST_OPENCV define wasn't in the C++ args, so fix that too.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 7b3314bd9..6eabbf1bc 100644
--- a/meson.build
+++ b/meson.build
@@ -70,6 +70,7 @@ if cc.get_id() == 'msvc'
export_define = '__declspec(dllexport) extern'
elif cc.has_argument('-fvisibility=hidden')
add_project_arguments('-fvisibility=hidden', language: 'c')
+ add_project_arguments('-fvisibility=hidden', language: 'cpp')
export_define = 'extern __attribute__ ((visibility ("default")))'
else
export_define = 'extern'