summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorTim-Philipp Müller <tim@centricular.com>2019-01-22 12:52:25 +0000
committerTim-Philipp Müller <tim@centricular.com>2019-01-22 12:52:25 +0000
commitc68fe0b365714fd843f31786fae773325d600328 (patch)
tree907ad9c7fba94f493732f8833f30c2e7e5683007 /meson.build
parent33701d78996de758cd7a2fa32ee6b513dc8fd748 (diff)
downloadgstreamer-plugins-bad-c68fe0b365714fd843f31786fae773325d600328.tar.gz
meson: detect opengl api from -base .pc files correctly
There was a mismatch between the .pc files generated by autotools and by meson that would lead to meson not detecting that opengl api is available even though it is. This could lead to build failures when building -bad with meson against a -base that was built with autotools. The mismatch has now been rectified but we will still check the old one for backwards compatibility.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build6
1 files changed, 5 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 6aa6659f0..4cb1b2088 100644
--- a/meson.build
+++ b/meson.build
@@ -307,8 +307,12 @@ if gstgl_dep.found()
set_variable('gst_gl_have_platform_@0@'.format(p), gst_gl_platforms.contains(p))
endforeach
- foreach api : ['opengl', 'gles2']
+ foreach api : ['gl', 'gles2']
set_variable('gst_gl_have_api_@0@'.format(api), gst_gl_apis.contains(api))
+ # temporary backwards compat for older meson-generated .pc file with 'opengl' instead of 'gl'
+ if gst_gl_apis.contains('opengl')
+ gst_gl_have_api_gl = true
+ endif
endforeach
endif