summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorTim-Philipp Müller <tim@centricular.com>2019-03-23 18:57:24 +0000
committerTim-Philipp Müller <tim@centricular.com>2019-03-23 18:57:24 +0000
commitcacd51fa9336e6e606f340b48e01a66034bea0ee (patch)
tree09832726c0614a4ee56b95004b3986b421100b67 /meson.build
parent054dc5282de069191f0d599631803a8eda03e12a (diff)
downloadgstreamer-plugins-bad-cacd51fa9336e6e606f340b48e01a66034bea0ee.tar.gz
g-i: silence 'nested extern' compiler warnings when building scanner binary
We need a nested extern in our init section for the scanner binary so we can call gst_init to make sure GStreamer types are initialised (they are not all lazy init via get_type functions, but some are in exported variables). There doesn't seem to be any other mechanism to achieve this, so just remove that warning, it's not important at all.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build1
1 files changed, 0 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 45a20394c..3c10943c0 100644
--- a/meson.build
+++ b/meson.build
@@ -189,7 +189,6 @@ warning_c_flags = [
'-Wmissing-prototypes',
'-Wdeclaration-after-statement',
'-Wold-style-definition',
- '-Wnested-externs',
]
warning_cxx_flags = [