summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorMatthew Waters <matthew@centricular.com>2020-07-24 17:31:36 +1000
committerMatthew Waters <matthew@centricular.com>2020-08-07 20:22:41 +1000
commitd1667da0c3f1865a50c3d0c99561fcd57d891bd7 (patch)
tree27649c820ecd09c06b40f9f085d5e3fbd9bdb441 /meson.build
parentfbbacdb856a1ace6917cd5a35c0d6a06b25ad06b (diff)
downloadgstreamer-plugins-bad-d1667da0c3f1865a50c3d0c99561fcd57d891bd7.tar.gz
build: update for gl pkg-config file split
Part-of: <https://gitlab.freedesktop.org/gstreamer/gst-plugins-bad/-/merge_requests/1462>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build26
1 files changed, 22 insertions, 4 deletions
diff --git a/meson.build b/meson.build
index 4a7468442..fdbae8556 100644
--- a/meson.build
+++ b/meson.build
@@ -300,6 +300,11 @@ gstcheck_dep = dependency('gstreamer-check-1.0', version : gst_req,
# GStreamer OpenGL
gstgl_dep = dependency('gstreamer-gl-1.0', version : gst_req,
fallback : ['gst-plugins-base', 'gstgl_dep'], required: get_option('gl'))
+gstglproto_dep = dependency('gstreamer-gl-prototypes-1.0', version : gst_req,
+ fallback : ['gst-plugins-base', 'gstglproto_dep'], required: get_option('gl'))
+gstglx11_dep = dependency('', required : false)
+gstglwayland_dep = dependency('', required : false)
+gstglegl_dep = dependency('', required : false)
if gstgl_dep.found()
if gstgl_dep.type_name() == 'pkgconfig'
@@ -327,11 +332,24 @@ if gstgl_dep.found()
foreach api : ['gl', 'gles2']
set_variable('gst_gl_have_api_@0@'.format(api), gst_gl_apis.contains(api))
- # temporary backwards compat for older meson-generated .pc file with 'opengl' instead of 'gl'
- if gst_gl_apis.contains('opengl')
- gst_gl_have_api_gl = true
- endif
endforeach
+
+ # Behind specific checks because meson fails at optional dependencies with a
+ # fallback to the same subproject. On the first failure, meson will never
+ # check the system again even if the fallback never existed.
+ # Last checked with meson 0.54.3
+ if gst_gl_have_window_x11
+ gstglx11_dep = dependency('gstreamer-gl-x11-1.0', version : gst_req,
+ fallback : ['gst-plugins-base', 'gstglx11_dep'], required: true)
+ endif
+ if gst_gl_have_window_wayland
+ gstglwayland_dep = dependency('gstreamer-gl-wayland-1.0', version : gst_req,
+ fallback : ['gst-plugins-base', 'gstglwayland_dep'], required: true)
+ endif
+ if gst_gl_have_platform_egl
+ gstglegl_dep = dependency('gstreamer-gl-egl-1.0', version : gst_req,
+ fallback : ['gst-plugins-base', 'gstglegl_dep'], required: true)
+ endif
endif
libm = cc.find_library('m', required : false)