summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorNirbheek Chauhan <nirbheek@centricular.com>2017-03-23 02:48:10 +0530
committerNirbheek Chauhan <nirbheek@centricular.com>2017-03-23 02:48:39 +0530
commitddcd7735b673a111bc73a3e58853a662d1e6c72e (patch)
tree856804e57009d05cf403b8b4f85dca160fc69265 /meson.build
parent40a2deef808b9a34d0a257134bf836962a5a1065 (diff)
downloadgstreamer-plugins-bad-ddcd7735b673a111bc73a3e58853a662d1e6c72e.tar.gz
meson: Build mpeg2enc and mplex when available
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build12
1 files changed, 12 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index be96e8d33..a3161a1cd 100644
--- a/meson.build
+++ b/meson.build
@@ -302,9 +302,21 @@ glib_dep = dependency('glib-2.0', version : glib_req)
gio_dep = dependency('gio-2.0', version : glib_req)
gmodule_dep = dependency('gmodule-2.0', version : glib_req)
x11_dep = dependency('x11', required : false)
+
# Used by dtls and hls
openssl_dep = dependency('openssl', version : '>= 1.0.1', required : false)
+# Used by mpeg2enc and mplex
+# mjpegtools upstream breaks API constantly and doesn't export the version in
+# a header anywhere. The configure file has a lot of logic to support old
+# versions, but it all seems untested and broken. Require 2.0.0. Can be changed
+# if someone complains.
+mjpegtools_dep = dependency('mjpegtools', version : '>=2.0.0', required : false)
+mjpegtools_api = '0'
+if mjpegtools_dep.found()
+ mjpegtools_api = '20000'
+endif
+
if x11_dep.found()
cdata.set('HAVE_X11', 1)
endif