summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorNirbheek Chauhan <nirbheek@centricular.com>2020-05-12 05:00:36 +0530
committerNirbheek Chauhan <nirbheek@centricular.com>2020-05-13 13:59:36 +0530
commite3d58492256fa02b40504ccee3852d81bd08505e (patch)
tree2e7d4a759cbba14d6a895017259db30966cc92e9 /meson.build
parent0a2e026985d86abe92e24ef546cb81a2e4b7cc10 (diff)
downloadgstreamer-plugins-bad-e3d58492256fa02b40504ccee3852d81bd08505e.tar.gz
meson: Pass native: false to add_languages()
This is needed for cross-compiling without a build machine compiler available. The option was added in 0.54, but we only need this in Cerbero and it doesn't affect older versions so it should be ok. Will only cause a spurious warning. Part-of: <https://gitlab.freedesktop.org/gstreamer/gst-plugins-bad/-/merge_requests/1266>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 2 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index fced76540..570f651ad 100644
--- a/meson.build
+++ b/meson.build
@@ -34,7 +34,7 @@ plugins = []
cc = meson.get_compiler('c')
cxx = meson.get_compiler('cpp')
-have_objc = add_languages('objc', required : false)
+have_objc = add_languages('objc', native: false, required: false)
cdata = configuration_data()
@@ -369,7 +369,7 @@ if ['darwin', 'ios'].contains(host_system)
# cdata.set('HAVE_VIDEOTOOLBOX_10_9_6', 1)
# endif
endif
-have_objcpp = add_languages('objcpp', required : false)
+have_objcpp = add_languages('objcpp', native: false, required: false)
have_orcc = false
orcc_args = []