summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorSeungha Yang <seungha.yang@navercorp.com>2018-12-07 23:22:08 +0900
committerTim-Philipp Müller <tim@centricular.com>2018-12-18 16:48:17 +0000
commitf74ad82ddcef0f18a43989aab25ee6d9fa37b98e (patch)
treec6e291d6c98473d1b70ce879dbeb6d7ec8ea1512 /meson.build
parent5b372a97077f392780e47abe230f3f4273926c40 (diff)
downloadgstreamer-plugins-bad-f74ad82ddcef0f18a43989aab25ee6d9fa37b98e.tar.gz
tests: Enable unit test on Windows
Allow run some unit tests on Windows. * Add dependency explicitly for some test cases, otherwise plugins couldn't be loaded on uninstalled environment of Windows. * Add missing GST_PLUGIN_LOADING_WHITELIST on meson build.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 1 insertions, 3 deletions
diff --git a/meson.build b/meson.build
index 83e1528b2..bd9dac735 100644
--- a/meson.build
+++ b/meson.build
@@ -405,11 +405,9 @@ gsttag_dep = dependency('gstreamer-tag-1.0', version : gst_req,
fallback : ['gst-plugins-base', 'tag_dep'])
gstvideo_dep = dependency('gstreamer-video-1.0', version : gst_req,
fallback : ['gst-plugins-base', 'video_dep'])
-if host_machine.system() != 'windows'
- gstcheck_dep = dependency('gstreamer-check-1.0', version : gst_req,
+gstcheck_dep = dependency('gstreamer-check-1.0', version : gst_req,
required : get_option('tests'),
fallback : ['gstreamer', 'gst_check_dep'])
-endif
# GStreamer OpenGL
gstgl_dep = dependency('gstreamer-gl-1.0', version : gst_req,