summaryrefslogtreecommitdiff
path: root/sys/meson.build
diff options
context:
space:
mode:
authorSeungha Yang <seungha.yang@navercorp.com>2018-11-22 12:14:44 +0900
committerTim-Philipp Müller <tim@centricular.com>2018-11-25 23:31:37 +0000
commit6bf5ba993d170c5a267fab9ce69e7eac68cf6759 (patch)
treed96b6a636a81f3fde5e88ea3005314faeed61e85 /sys/meson.build
parent6051c47bfe3d98f96012f79e63f2b7fae618379e (diff)
downloadgstreamer-plugins-bad-6bf5ba993d170c5a267fab9ce69e7eac68cf6759.tar.gz
nvenc: Add meson build with Windows support
Note that, since Nvidia does not provide nvEncodeAPI.lib file, find_library() couldn't be used for build on Windows. This patch changes to load nvEncodeAPI(64).dll or libnvidia-encode.so in runtime
Diffstat (limited to 'sys/meson.build')
-rw-r--r--sys/meson.build4
1 files changed, 3 insertions, 1 deletions
diff --git a/sys/meson.build b/sys/meson.build
index 8a1363fab..7b7e92de1 100644
--- a/sys/meson.build
+++ b/sys/meson.build
@@ -106,7 +106,9 @@ endif
if cuda_dep.found() and cudart_dep.found()
subdir('nvdec')
- #subdir('nvenc')
+ subdir('nvenc')
elif get_option('nvdec').enabled()
error('The nvdec plugin was enabled explicitly, but required CUDA dependencies were not found.')
+elif get_option('nvenc').enabled()
+ error('The nvenc plugin was enabled explicitly, but required CUDA dependencies were not found.')
endif \ No newline at end of file