summaryrefslogtreecommitdiff
path: root/sys/msdk/Makefile.am
diff options
context:
space:
mode:
authorHyunjun Ko <zzoon@igalia.com>2018-02-13 12:41:28 -0900
committerSreerenj Balachandran <sreerenj.balachandran@intel.com>2018-02-13 12:41:28 -0900
commit6ce9a66b80c6b5d72feff1d74bf08f3e71e18330 (patch)
tree7d5f9342ff4649ed27d4a82f72a992f75118d1b8 /sys/msdk/Makefile.am
parent3f9d0fcaa97b47a2afda863a4dcd7f008f61a43a (diff)
downloadgstreamer-plugins-bad-6ce9a66b80c6b5d72feff1d74bf08f3e71e18330.tar.gz
msdk: implements GstMsdkContext.
Makes GstMsdkContext to be a descendant of GstObject so that we could track the life-cycle of the session of the driver. Also replaces MsdkContext with this one. Keeps msdk_d3d.c alive for the future. https://bugzilla.gnome.org/show_bug.cgi?id=790752
Diffstat (limited to 'sys/msdk/Makefile.am')
-rw-r--r--sys/msdk/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/sys/msdk/Makefile.am b/sys/msdk/Makefile.am
index 20bbbbb6a..104ee1e5b 100644
--- a/sys/msdk/Makefile.am
+++ b/sys/msdk/Makefile.am
@@ -1,6 +1,7 @@
plugin_LTLIBRARIES = libgstmsdk.la
libgstmsdk_la_SOURCES = \
+ gstmsdkcontext.c \
gstmsdkh264dec.c \
gstmsdkh264enc.c \
gstmsdkh265dec.c \
@@ -20,6 +21,7 @@ nodist_EXTRA_libgstmsdk_la_SOURCES = not_present.cxx
noinst_HEADERS = \
msdk.h \
+ gstmsdkcontext.h \
gstmsdkh264dec.h \
gstmsdkh264enc.h \
gstmsdkh265dec.h \