summaryrefslogtreecommitdiff
path: root/sys/nvcodec/meson.build
diff options
context:
space:
mode:
authorSeungha Yang <seungha.yang@navercorp.com>2018-11-23 22:01:41 +0900
committerMatthew Waters <matthew@centricular.com>2019-08-07 00:59:36 +0000
commit094e4a9f5c185b28491870518d962b8c5c0195e7 (patch)
tree0cba82a97f28fa4b3060b7146c1b1ee50c3087df /sys/nvcodec/meson.build
parentaea20f207db7a4203bafab92c0e800c811c1ec48 (diff)
downloadgstreamer-plugins-bad-094e4a9f5c185b28491870518d962b8c5c0195e7.tar.gz
nvcodec: Introduce NVIDA CUDA helpers
New object and helper functions can remove duplicated code from nvenc/nvdec. Also this is prework for CUDA device context sharing among nvdec(s)/nvenc(s).
Diffstat (limited to 'sys/nvcodec/meson.build')
-rw-r--r--sys/nvcodec/meson.build2
1 files changed, 2 insertions, 0 deletions
diff --git a/sys/nvcodec/meson.build b/sys/nvcodec/meson.build
index aefb94152..b8d46f6f9 100644
--- a/sys/nvcodec/meson.build
+++ b/sys/nvcodec/meson.build
@@ -7,6 +7,8 @@ nvcodec_sources = [
'gstcudaloader.c',
'gstnvdec.c',
'gstcuvidloader.c',
+ 'gstcudacontext.c',
+ 'gstcudautils.c',
]
if get_option('nvcodec').disabled()