summaryrefslogtreecommitdiff
path: root/tests/examples/va/meson.build
diff options
context:
space:
mode:
authorHe Junyan <junyan.he@intel.com>2021-05-07 17:05:38 +0800
committerVíctor Manuel Jáquez Leal <vjaquez@igalia.com>2021-05-18 12:15:36 +0200
commitc335f00d626eb8c83fea19d7fcbcd1b8e9157e5d (patch)
treec9447f0d7a21c0c604ddac478b9ffacd94fed01d /tests/examples/va/meson.build
parent031b77ce97976eeae9d2c24b84020d1422f026ab (diff)
downloadgstreamer-plugins-bad-c335f00d626eb8c83fea19d7fcbcd1b8e9157e5d.tar.gz
examples: va: Update the VA examples because of the new va lib.
Because we introduce the new va lib, the va examples need to include new header files and add more library linkage. Part-of: <https://gitlab.freedesktop.org/gstreamer/gst-plugins-bad/-/merge_requests/2196>
Diffstat (limited to 'tests/examples/va/meson.build')
-rw-r--r--tests/examples/va/meson.build8
1 files changed, 4 insertions, 4 deletions
diff --git a/tests/examples/va/meson.build b/tests/examples/va/meson.build
index 5dc602054..4f50b3eb5 100644
--- a/tests/examples/va/meson.build
+++ b/tests/examples/va/meson.build
@@ -1,4 +1,4 @@
-if not have_va
+if not gstva_dep.found()
subdir_done()
endif
@@ -7,12 +7,12 @@ gtk_x11_dep = dependency('gtk+-x11-3.0', required : get_option('examples'))
x11_dep = dependency('x11', required : get_option('examples'))
libva_x11_dep = dependency('libva-x11', version: libva_req, required: get_option('examples'))
-if have_va and gtk_dep.found() and gtk_x11_dep.found() and x11_dep.found() and libva_x11_dep.found()
+if gtk_dep.found() and gtk_x11_dep.found() and x11_dep.found() and libva_x11_dep.found()
executable('va-x11-render',
'main.c',
install: false,
include_directories : [configinc],
- dependencies : [gtk_dep, gtk_x11_dep, x11_dep, gst_dep, gstapp_dep, gstvideo_dep, libva_dep, libva_x11_dep],
+ dependencies : [gtk_dep, gtk_x11_dep, x11_dep, gst_dep, gstapp_dep, gstvideo_dep, gstva_dep, libva_x11_dep],
c_args : gst_plugins_bad_args + ['-DGST_USE_UNSTABLE_API'],
)
endif
@@ -21,6 +21,6 @@ executable('multiple-vpp',
'multiple-vpp.c',
install: false,
include_directories : [configinc],
- dependencies : [gst_dep, gstvideo_dep, gstcontroller_dep],
+ dependencies : [gst_dep, gstvideo_dep, gstva_dep, gstcontroller_dep],
c_args : gst_plugins_bad_args + ['-DGST_USE_UNSTABLE_API'],
)