summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am36
1 files changed, 4 insertions, 32 deletions
diff --git a/Makefile.am b/Makefile.am
index ae2e7daaf..861c257ba 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,38 +1,10 @@
-# if USE_GCONFTOOL
-# GCONF_DIR = gconf
-# else
-GCONF_DIR =
-# endif
-
-SUBDIRS = \
- gst sys ext gst-libs \
- $(GCONF_DIR) \
- m4 common po
-# disabled
-# $(SUBDIRS_DOCS)
-
-DIST_SUBDIRS = \
- gst sys ext gst-libs \
+SUBDIRS = \
+ gst sys ext \
m4 common po
EXTRA_DIST = \
- gst-plugins.spec depcomp \
- AUTHORS COPYING COPYING.LIB NEWS README RELEASE REQUIREMENTS \
+ gst-plugins-bad.spec depcomp \
+ AUTHORS COPYING NEWS README RELEASE REQUIREMENTS \
ChangeLog autogen.sh
DISTCLEANFILES = _stdint.h
-
-# check that no marshal or enumtypes files are included
-# this in turn ensures that distcheck fails for missing .list files which is currently
-# shadowed when the corresponding .c and .h files are included.
-distcheck-hook:
- @test "x" = "x`find $(distdir) -name \*-enumtypes.[ch]`" && \
- test "x" = "x`find $(distdir) -name \*-marshal.[ch]`" || \
- ( $(ECHO) "*** Leftover enumtypes or marshal files in the tarball." && \
- $(ECHO) "*** Make sure the following files are not disted:" && \
- find $(distdir) -name \*-enumtypes.[ch] && \
- find $(distdir) -name \*-marshal.[ch] && \
- false )
-
-# include $(top_srcdir)/common/release.mak
-# include $(top_srcdir)/common/po.mak