summaryrefslogtreecommitdiff
path: root/ext/opus/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'ext/opus/meson.build')
-rw-r--r--ext/opus/meson.build20
1 files changed, 20 insertions, 0 deletions
diff --git a/ext/opus/meson.build b/ext/opus/meson.build
new file mode 100644
index 000000000..22ee796e2
--- /dev/null
+++ b/ext/opus/meson.build
@@ -0,0 +1,20 @@
+opus_sources = [
+ 'gstopus.c',
+ 'gstopusheader.c',
+ 'gstopusparse.c',
+]
+
+opus_dep = dependency('opus', version : '>= 0.9.4', required : false)
+
+if opus_dep.found()
+ gstopus = library('gstopusparse',
+ opus_sources,
+ c_args : gst_plugins_bad_args,
+ link_args : noseh_link_args,
+ include_directories : [configinc],
+ dependencies : [gstrtp_dep, gstpbutils_dep, gstaudio_dep,
+ gsttag_dep, opus_dep, libm],
+ install : true,
+ install_dir : plugins_install_dir,
+ )
+endif