summaryrefslogtreecommitdiff
path: root/ext/smoothstreaming/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'ext/smoothstreaming/meson.build')
-rw-r--r--ext/smoothstreaming/meson.build20
1 files changed, 20 insertions, 0 deletions
diff --git a/ext/smoothstreaming/meson.build b/ext/smoothstreaming/meson.build
new file mode 100644
index 000000000..00afda948
--- /dev/null
+++ b/ext/smoothstreaming/meson.build
@@ -0,0 +1,20 @@
+smoothstreaming_sources = [
+ 'gstmssdemux.c',
+ 'gstmssmanifest.c',
+ 'gstsmoothstreaming-plugin.c',
+]
+
+xml28_dep = dependency('libxml-2.0', version : '>= 2.8', required : false)
+
+if xml28_dep.found()
+ gstmss = library('gstsmoothstreaming',
+ smoothstreaming_sources,
+ c_args : gst_plugins_bad_args + ['-DGST_USE_UNSTABLE_API'],
+ link_args : noseh_link_args,
+ include_directories : [configinc, libsinc],
+ dependencies : [gst_dep, gstadaptivedemux_dep, gstcodecparsers_dep,
+ gsturidownloader_dep, xml28_dep],
+ install : true,
+ install_dir : plugins_install_dir,
+ )
+endif