summaryrefslogtreecommitdiff
path: root/ext/soundtouch/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'ext/soundtouch/meson.build')
-rw-r--r--ext/soundtouch/meson.build32
1 files changed, 32 insertions, 0 deletions
diff --git a/ext/soundtouch/meson.build b/ext/soundtouch/meson.build
new file mode 100644
index 000000000..e4143d8a4
--- /dev/null
+++ b/ext/soundtouch/meson.build
@@ -0,0 +1,32 @@
+soundtouch_sources = [
+ 'plugin.c',
+ 'gstpitch.cc',
+ 'gstbpmdetect.cc',
+]
+
+soundtouch_cargs = ['-DHAVE_SOUNDTOUCH']
+
+soundtouch_dep = dependency('soundtouch', required : false)
+if soundtouch_dep.found()
+ soundtouch_cargs += ['-DHAVE_SOUNDTOUCH_1_4']
+else
+ soundtouch_dep = dependency('soundtouch-1.4', required : false)
+ if soundtouch_dep.found()
+ soundtouch_cargs += ['-DHAVE_SOUNDTOUCH_1_4']
+ else
+ soundtouch_dep = dependency('soundtouch-1.0', required : false)
+ # NOTE: I removed the checks for libSoundTouch.pc and so on.
+ # Add them back once we know which distros use them.
+ endif
+endif
+
+if soundtouch_dep.found()
+ gstsoundtouch = library('gstsoundtouch',
+ soundtouch_sources,
+ c_args : gst_plugins_bad_args + soundtouch_cargs,
+ cpp_args : gst_plugins_bad_args + soundtouch_cargs,
+ include_directories : [configinc],
+ dependencies : [gstaudio_dep, soundtouch_dep],
+ install : true,
+ install_dir : plugins_install_dir)
+endif