summaryrefslogtreecommitdiff
path: root/ext/spandsp/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'ext/spandsp/meson.build')
-rw-r--r--ext/spandsp/meson.build22
1 files changed, 22 insertions, 0 deletions
diff --git a/ext/spandsp/meson.build b/ext/spandsp/meson.build
new file mode 100644
index 000000000..34c9bc841
--- /dev/null
+++ b/ext/spandsp/meson.build
@@ -0,0 +1,22 @@
+spandsp_sources = [
+ 'gstdtmfdetect.c',
+ 'gstdtmfdetect.h',
+ 'gstspandsp.c',
+ 'gstspanplc.c',
+ 'gstspanplc.h',
+ 'gsttonegeneratesrc.c',
+ 'gsttonegeneratesrc.h',
+]
+
+spandsp_dep = dependency('spandsp', version : '>= 0.0.6', required : false)
+
+if spandsp_dep.found()
+ gstspandsp = library('gstspandsp',
+ spandsp_sources,
+ c_args : gst_plugins_bad_args,
+ include_directories : [configinc],
+ dependencies : [gstvideo_dep, spandsp_dep],
+ install : true,
+ install_dir : plugins_install_dir,
+ )
+endif