summaryrefslogtreecommitdiff
path: root/ext/voaacenc/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'ext/voaacenc/meson.build')
-rw-r--r--ext/voaacenc/meson.build15
1 files changed, 15 insertions, 0 deletions
diff --git a/ext/voaacenc/meson.build b/ext/voaacenc/meson.build
new file mode 100644
index 000000000..0f2eec38c
--- /dev/null
+++ b/ext/voaacenc/meson.build
@@ -0,0 +1,15 @@
+voaac_sources = ['gstvoaac.c', 'gstvoaacenc.c']
+
+voaac_dep = dependency('vo-aacenc', required : false)
+
+if voaac_dep.found()
+ gstbz2 = library('gstvoaacenc',
+ voaac_sources,
+ c_args : gst_plugins_bad_args,
+ link_args : noseh_link_args,
+ include_directories : [configinc],
+ dependencies : [gstbase_dep, gstpbutils_dep, gstaudio_dep, voaac_dep],
+ install : true,
+ install_dir : plugins_install_dir,
+ )
+endif