summaryrefslogtreecommitdiff
path: root/ext/webp/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'ext/webp/Makefile.am')
-rw-r--r--ext/webp/Makefile.am17
1 files changed, 17 insertions, 0 deletions
diff --git a/ext/webp/Makefile.am b/ext/webp/Makefile.am
new file mode 100644
index 000000000..25c35571e
--- /dev/null
+++ b/ext/webp/Makefile.am
@@ -0,0 +1,17 @@
+plugin_LTLIBRARIES = libgstwebp.la
+
+noinst_HEADERS = gstwebpdec.h
+
+libgstwebp_la_SOURCES = gstwebp.c \
+ gstwebpdec.c
+
+libgstwebp_la_CFLAGS = $(GST_PLUGINS_BASE_CFLAGS) $(GST_BASE_CFLAGS) $(GST_CFLAGS) $(WEBP_CFLAGS)
+libgstwebp_la_LIBADD = \
+ $(GST_PLUGINS_BASE_LIBS) \
+ -lgstvideo-$(GST_API_VERSION) \
+ $(GST_BASE_LIBS) \
+ $(GST_LIBS) \
+ $(WEBP_LIBS)
+libgstwebp_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS)
+libgstwebp_la_LIBTOOLFLAGS = $(GST_PLUGIN_LIBTOOLFLAGS)
+