summaryrefslogtreecommitdiff
path: root/ext/wpe/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'ext/wpe/meson.build')
-rw-r--r--ext/wpe/meson.build7
1 files changed, 6 insertions, 1 deletions
diff --git a/ext/wpe/meson.build b/ext/wpe/meson.build
index 580d6649c..b46ae9567 100644
--- a/ext/wpe/meson.build
+++ b/ext/wpe/meson.build
@@ -16,12 +16,17 @@ if not wpe_dep.found() or not wpe_fdo_dep.found() or not egl_dep.found() or not
subdir_done()
endif
+giounix_dep = dependency('gio-unix-2.0', required: false)
gstwpe = library('gstwpe',
['WPEThreadedView.cpp', 'gstwpe.cpp', 'gstwpevideosrc.cpp', 'gstwpesrcbin.cpp'],
- dependencies : [egl_dep, wpe_dep, wpe_fdo_dep, gstallocators_dep, gstaudio_dep, gstvideo_dep, gstbase_dep, gstgl_dep, xkbcommon_dep, wl_server_dep],
+ dependencies : [egl_dep, wpe_dep, wpe_fdo_dep, gstallocators_dep, gstaudio_dep, gstvideo_dep, gstbase_dep, gstgl_dep, xkbcommon_dep, wl_server_dep, giounix_dep],
cpp_args : gst_plugins_bad_args + ['-DHAVE_CONFIG_H=1'],
include_directories : [configinc],
install : true,
install_dir : plugins_install_dir)
+
+if giounix_dep.found()
+ subdir('wpe-extension')
+endif
pkgconfig.generate(gstwpe, install_dir : plugins_pkgconfig_install_dir)
plugins += [gstwpe]