summaryrefslogtreecommitdiff
path: root/gst-libs/gst/base/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'gst-libs/gst/base/meson.build')
-rw-r--r--gst-libs/gst/base/meson.build18
1 files changed, 18 insertions, 0 deletions
diff --git a/gst-libs/gst/base/meson.build b/gst-libs/gst/base/meson.build
new file mode 100644
index 000000000..34203edf4
--- /dev/null
+++ b/gst-libs/gst/base/meson.build
@@ -0,0 +1,18 @@
+badbase_sources = ['gstaggregator.c']
+badbase_headers = ['gstaggregator.h']
+install_headers(badbase_headers, subdir : 'gstreamer-1.0/gst/base')
+
+gstbadbase = library('gstbadbase-' + api_version,
+ badbase_sources,
+ c_args : gst_plugins_bad_args + ['-DGST_USE_UNSTABLE_API'],
+ include_directories : [configinc, libsinc],
+ version : libversion,
+ soversion : soversion,
+ install : true,
+ dependencies : [gst_dep],
+ vs_module_defs: vs_module_defs_dir + 'libgstbadbase.def',
+)
+
+gstbadbase_dep = declare_dependency(link_with : gstbadbase,
+ include_directories : [libsinc],
+ dependencies : [gst_dep])