summaryrefslogtreecommitdiff
path: root/gst/codecalpha/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'gst/codecalpha/meson.build')
-rw-r--r--gst/codecalpha/meson.build15
1 files changed, 15 insertions, 0 deletions
diff --git a/gst/codecalpha/meson.build b/gst/codecalpha/meson.build
new file mode 100644
index 000000000..1c9d3b34e
--- /dev/null
+++ b/gst/codecalpha/meson.build
@@ -0,0 +1,15 @@
+codecalpha_sources = [
+ 'gstplugin.c',
+ 'gstcodecalphademux.c',
+]
+
+gstcodecalpha = library('gstcodecalpha',
+ codecalpha_sources,
+ c_args : gst_plugins_bad_args,
+ include_directories : [configinc],
+ dependencies : [gstvideo_dep],
+ install : true,
+ install_dir : plugins_install_dir,
+)
+pkgconfig.generate(gstcodecalpha, install_dir : plugins_pkgconfig_install_dir)
+plugins += [gstcodecalpha]