summaryrefslogtreecommitdiff
path: root/sys/directsound/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'sys/directsound/meson.build')
-rw-r--r--sys/directsound/meson.build16
1 files changed, 16 insertions, 0 deletions
diff --git a/sys/directsound/meson.build b/sys/directsound/meson.build
new file mode 100644
index 000000000..c48adc1ae
--- /dev/null
+++ b/sys/directsound/meson.build
@@ -0,0 +1,16 @@
+directsoundsrc_sources = [
+ 'gstdirectsoundsrc.c',
+ 'gstdirectsoundplugin.c',
+]
+
+if host_system == 'windows' and cc.has_header('dsound.h')
+ directsoundsrc_dep = [cc.find_library('dsound'), cc.find_library('winmm')]
+
+ gstdirectsoundsrc = library('gstdirectsoundsrc',
+ directsoundsrc_sources,
+ c_args : gst_plugins_bad_args,
+ include_directories : [configinc],
+ dependencies : [gstaudio_dep] + directsoundsrc_dep,
+ install : true,
+ install_dir : plugins_install_dir)
+endif