summaryrefslogtreecommitdiff
path: root/tests/examples/waylandsink/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tests/examples/waylandsink/Makefile.am')
-rw-r--r--tests/examples/waylandsink/Makefile.am18
1 files changed, 16 insertions, 2 deletions
diff --git a/tests/examples/waylandsink/Makefile.am b/tests/examples/waylandsink/Makefile.am
index f5ba921ec..3e9577565 100644
--- a/tests/examples/waylandsink/Makefile.am
+++ b/tests/examples/waylandsink/Makefile.am
@@ -1,5 +1,7 @@
-noinst_PROGRAMS = gtkwaylandsink
+GST_WAYLANDSINK_UI_FILES = window.ui
+if HAVE_GTK3_WAYLAND
+GST_WAYLANDSINK_GTK_EXAMPLE = gtkwaylandsink
gtkwaylandsink_SOURCES = main.c
gtkwaylandsink_CFLAGS=-I$(top_srcdir)/gst-libs -I$(top_builddir)/gst-libs \
@@ -7,5 +9,17 @@ gtkwaylandsink_CFLAGS=-I$(top_srcdir)/gst-libs -I$(top_builddir)/gst-libs \
gtkwaylandsink_LDADD=$(GTK3_LIBS) $(GST_PLUGINS_BASE_LIBS) $(GST_LIBS) \
-lgstvideo-$(GST_API_VERSION) \
$(top_builddir)/gst-libs/gst/wayland/libgstwayland-$(GST_API_VERSION).la
+else
+GST_WAYLANDSINK_GTK_EXAMPLE =
+endif
-EXTRA_DIST = window.ui
+wayland_threads_SOURCES = wayland-threads.c
+wayland_threads_CFLAGS=-I$(top_srcdir)/gst-libs -I$(top_builddir)/gst-libs \
+ $(GST_PLUGINS_BASE_CFLAGS) $(GST_CFLAGS) $(WAYLAND_CFLAGS)
+wayland_threads_LDADD=$(GST_PLUGINS_BASE_LIBS) $(GST_LIBS) $(WAYLAND_LIBS)\
+ -lgstvideo-$(GST_API_VERSION) \
+ $(top_builddir)/gst-libs/gst/wayland/libgstwayland-$(GST_API_VERSION).la
+
+noinst_PROGRAMS = $(GST_WAYLANDSINK_GTK_EXAMPLE) wayland_threads
+
+EXTRA_DIST = $(GST_WAYLANDSINK_UI_FILES)