summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorNirbheek Chauhan <nirbheek@centricular.com>2020-05-12 04:58:24 +0530
committerNirbheek Chauhan <nirbheek@centricular.com>2020-05-12 05:08:59 +0530
commit4e7d3b42ec3fe1f4ca397fc27c908674b6af275b (patch)
treef99e5859dddfe56b69e49c799ff28d510b80649f /meson.build
parent9280d4b8f512565003bf8e310681394c1611d3c1 (diff)
downloadgstreamer-plugins-base-4e7d3b42ec3fe1f4ca397fc27c908674b6af275b.tar.gz
meson: Pass native: false to add_languages()
This is needed for cross-compiling without a build machine compiler available. The option was added in 0.54, but we only need this in Cerbero and it doesn't affect older versions so it should be ok. Will only cause a spurious warning. Part-of: <https://gitlab.freedesktop.org/gstreamer/gst-plugins-base/-/merge_requests/660>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 2 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index 92958ed3c..63a14b870 100644
--- a/meson.build
+++ b/meson.build
@@ -16,8 +16,8 @@ else
endif
gst_version_is_dev = gst_version_minor % 2 == 1 and gst_version_micro < 90
-have_cxx = add_languages('cpp', required : false)
-have_objc = add_languages('objc', required : false)
+have_cxx = add_languages('cpp', native: false, required: false)
+have_objc = add_languages('objc', native: false, required: false)
glib_req = '>= 2.44.0'
orc_req = '>= 0.4.24'