summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorMatthew Waters <matthew@centricular.com>2020-10-09 12:25:21 +1100
committerGStreamer Merge Bot <gitlab-merge-bot@gstreamer-foundation.org>2020-10-09 06:12:30 +0000
commited8f90c9300905b6156407aac63b182271482dfc (patch)
tree7539238b29e2216397352bf865f474d9dcd9842a /meson.build
parentc272a5e1a5c08cfa43ea6af4783f9a2d125f2408 (diff)
downloadgstreamer-plugins-base-ed8f90c9300905b6156407aac63b182271482dfc.tar.gz
build: use cpu_family for arch checks
e.g. on 32-bit arm, we may have armv6, armv7l, armv7hf, etc which all generally have the same layouts. cpu_family() groups all of these into just 'arm' that the ABI check table is expecting. Part-of: <https://gitlab.freedesktop.org/gstreamer/gst-plugins-base/-/merge_requests/854>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 5d1d32961..897d9ac23 100644
--- a/meson.build
+++ b/meson.build
@@ -130,7 +130,7 @@ host_defines = [
[ 's390', 'HAVE_CPU_S390' ],
]
foreach h : host_defines
- if h.get(0) == host_machine.cpu()
+ if h.get(0) == host_machine.cpu_family()
core_conf.set(h.get(1), 1)
endif
endforeach