summaryrefslogtreecommitdiff
path: root/docs/meson.build
diff options
context:
space:
mode:
authorThibault Saunier <tsaunier@igalia.com>2020-06-03 18:37:22 -0400
committerThibault Saunier <tsaunier@igalia.com>2020-06-03 18:50:10 -0400
commit45c2f827465651cc140d57f37898933b46d67b9b (patch)
treeb4b3dd53a0700cd7920e6d9eaf7274520d7cd1f0 /docs/meson.build
parent8e400a56346f4ea7065a95b02185a5de488c35d0 (diff)
downloadgstreamer-vaapi-45c2f827465651cc140d57f37898933b46d67b9b.tar.gz
doc: Require hotdoc >= 0.11.0
Diffstat (limited to 'docs/meson.build')
-rw-r--r--docs/meson.build11
1 files changed, 11 insertions, 0 deletions
diff --git a/docs/meson.build b/docs/meson.build
index 280cedbb..b9ad1386 100644
--- a/docs/meson.build
+++ b/docs/meson.build
@@ -35,6 +35,17 @@ if not hotdoc_p.found()
subdir_done()
endif
+hotdoc_req = '>= 0.11.0'
+hotdoc_version = run_command(hotdoc_p, '--version').stdout()
+if not hotdoc_version.version_compare(hotdoc_req)
+ if get_option('doc').enabled()
+ error('Hotdoc version @0@ not found, got @1@'.format(hotdoc_req, hotdoc_version))
+ else
+ message('Hotdoc version @0@ not found, got @1@'.format(hotdoc_req, hotdoc_version))
+ subdir_done()
+ endif
+endif
+
build_hotdoc = true
hotdoc = import('hotdoc')
if not hotdoc.has_extensions(required_hotdoc_extensions)