summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorXavier Claessens <xavier.claessens@collabora.com>2022-09-12 09:46:43 -0400
committerGStreamer Marge Bot <gitlab-merge-bot@gstreamer-foundation.org>2022-09-20 10:08:15 +0000
commit5f0493d33af685ea3fce8ea1d0e3b8c3c65cbcc4 (patch)
treeeae81d984cb7187e66931f188beaab4295544cc4 /meson.build
parentccef26908ef530889c526f30dc2f27b7110a531f (diff)
downloadgstreamer-5f0493d33af685ea3fce8ea1d0e3b8c3c65cbcc4.tar.gz
meson: Set install_tag on some targets
Trying to follow recommendation from Meson documentation: https://mesonbuild.com/Installing.html#installation-tags Move tools into 'bin' or 'bin-devel' categories to keep only libs and plugins in the default 'runtime' category. This simplifies distribution of GStreamer application skipping parts that are not needed, similarly to what Cerbero does by hardcoding huge list of files. Part-of: <https://gitlab.freedesktop.org/gstreamer/gstreamer/-/merge_requests/3017>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 2 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 706a0ddadd..0df45b3e7d 100644
--- a/meson.build
+++ b/meson.build
@@ -443,6 +443,7 @@ if building_full
exe_name = '@0@-@1@'.format(tool, apiversion)
extra_args = data.get('extra_c_args', [])
sources = data.get('files')
+ install_tag = data.get('install_tag', 'bin')
deps = []
foreach d : data.get('deps', [])
if d not in exposed_deps
@@ -453,6 +454,7 @@ if building_full
executable(exe_name,
sources,
install: true,
+ install_tag: install_tag,
include_directories : [configinc],
dependencies : [gst_full_dep] + deps,
c_args: extra_args + gst_c_args + ['-DG_LOG_DOMAIN="@0@"'.format(exe_name)],