summaryrefslogtreecommitdiff
path: root/gtk/Makefile.am
diff options
context:
space:
mode:
authorBenjamin Otte <otte@redhat.com>2013-08-20 15:35:58 +0200
committerBenjamin Otte <otte@redhat.com>2013-08-20 16:34:29 +0200
commite38e47d7d38f21aa62ebe7580c6250f327593ef2 (patch)
tree3e9eccf1696967949513dce32ec30ec2aaeaef83 /gtk/Makefile.am
parentaee5bcf9e2dabc1eb21280be2c42a1ac9b5ac39d (diff)
downloadgtk+-e38e47d7d38f21aa62ebe7580c6250f327593ef2.tar.gz
clipboard: Reimplement Wayland clipboard using vfuncs
This way, the Wayland and the regular clipboard implementation can both be compiled in and selected based on the display in use. One thing potentially broken now is text mime type handling as Wayland seemed to use different mime types in some places.
Diffstat (limited to 'gtk/Makefile.am')
-rw-r--r--gtk/Makefile.am10
1 files changed, 2 insertions, 8 deletions
diff --git a/gtk/Makefile.am b/gtk/Makefile.am
index 1891435267..48d83758ce 100644
--- a/gtk/Makefile.am
+++ b/gtk/Makefile.am
@@ -427,6 +427,7 @@ gtk_private_h_sources = \
gtkcairoblurprivate.h \
gtkcellareaboxcontextprivate.h \
gtkclipboardprivate.h \
+ gtkclipboard-waylandprivate.h \
gtkcolorswatchprivate.h \
gtkcoloreditorprivate.h \
gtkcolorplaneprivate.h \
@@ -1018,18 +1019,11 @@ gtk_clipboard_dnd_c_sources = \
gtkclipboard-quartz.c \
gtkdnd-quartz.c
else
-if USE_WAYLAND
-if !USE_X11
# No wayland gtkdnd-wayland.c yet
gtk_clipboard_dnd_c_sources = \
+ gtkclipboard.c \
gtkclipboard-wayland.c \
gtkdnd.c
-else
-gtk_clipboard_dnd_c_sources = gtkclipboard.c gtkdnd.c
-endif
-else
-gtk_clipboard_dnd_c_sources = gtkclipboard.c gtkdnd.c
-endif
endif
# we use our own built_sources variable rules to avoid automake's