summaryrefslogtreecommitdiff
path: root/gtk/Makefile.am
diff options
context:
space:
mode:
authorKristian Rietveld <kris@gtk.org>2003-07-11 12:51:24 +0000
committerKristian Rietveld <kristian@src.gnome.org>2003-07-11 12:51:24 +0000
commitedef7d00d99561796ae2a5fba9576ac1eaaba0a1 (patch)
treebccb75e8a7a9e88b89cc9feeb0a4ef2cbc70fae0 /gtk/Makefile.am
parent8aafd6bb1682ab4c85b78c692c2d8e779d158d7d (diff)
downloadgtk+-edef7d00d99561796ae2a5fba9576ac1eaaba0a1.tar.gz
Landing GtkTreeModelFilter and the completion code. (Test program and
Fri Jul 11 14:32:43 2003 Kristian Rietveld <kris@gtk.org> Landing GtkTreeModelFilter and the completion code. (Test program and documentation will follow next week). * gtk/gtkcellayout.[ch], gtk/gtkentrycompletion.[ch], gtk/gtktreemodelfilter.[ch], gtk/gtkentryprivate.h: new files. * gtkentry.[ch]: added gtk_entry_{get,set}_completion, wrote necessary code to hook up completion. * gtktreeviewcolumn.c: made GtkTreeViewColumn implement the new GtkCellLayout interface. * gtkmarshalers.list: added BOOLEAN:OBJECT,BOXED. * gtk/gtk.h, gtk/Makefile.am, po/POTFILES.in: all updated for the new source files.
Diffstat (limited to 'gtk/Makefile.am')
-rw-r--r--gtk/Makefile.am7
1 files changed, 7 insertions, 0 deletions
diff --git a/gtk/Makefile.am b/gtk/Makefile.am
index 3d0fc73cc5..abca8097bc 100644
--- a/gtk/Makefile.am
+++ b/gtk/Makefile.am
@@ -102,6 +102,7 @@ gtk_public_h_sources = \
gtkbutton.h \
gtkcalendar.h \
gtkcelleditable.h \
+ gtkcelllayout.h \
gtkcellrenderer.h \
gtkcellrendererpixbuf.h \
gtkcellrenderertext.h \
@@ -124,6 +125,7 @@ gtk_public_h_sources = \
gtkdrawingarea.h \
gtkeditable.h \
gtkentry.h \
+ gtkentrycompletion.h \
gtkenums.h \
gtkeventbox.h \
gtkexpander.h \
@@ -221,6 +223,7 @@ gtk_public_h_sources = \
gtktreednd.h \
gtktreeitem.h \
gtktreemodel.h \
+ gtktreemodelfilter.h \
gtktreemodelsort.h \
gtktreeselection.h \
gtktreesortable.h \
@@ -241,6 +244,7 @@ gtk_public_h_sources = \
# GTK+ header files that don't get installed
gtk_private_h_sources = \
+ gtkentryprivate.h \
gtkrbtree.h \
gtktextbtree.h \
gtktextchildprivate.h \
@@ -277,6 +281,7 @@ gtk_c_sources = \
gtkbox.c \
gtkbutton.c \
gtkcalendar.c \
+ gtkcelllayout.c \
gtkcellrenderer.c \
gtkcelleditable.c \
gtkcellrenderertext.c \
@@ -299,6 +304,7 @@ gtk_c_sources = \
gtkdrawingarea.c \
gtkeditable.c \
gtkentry.c \
+ gtkentrycompletion.c \
gtkeventbox.c \
gtkexpander.c \
gtkfilesel.c \
@@ -403,6 +409,7 @@ gtk_c_sources = \
gtktreedatalist.c \
gtktreednd.c \
gtktreemodel.c \
+ gtktreemodelfilter.c \
gtktreemodelsort.c \
gtktreeselection.c \
gtktreesortable.c \