summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorChun-wei Fan <fanchunwei@src.gnome.org>2023-03-07 14:27:06 +0800
committerChun-wei Fan <fanchunwei@src.gnome.org>2023-03-07 15:36:42 +0800
commit432e8664e1eb24c81bbcf1927f0de257bae7e038 (patch)
tree54b3a995bc765c10178c0b6555fc242516526d99 /meson.build
parent6d2c5e51e0d8f002246015f574c93d3a9a494903 (diff)
downloadgtk+-432e8664e1eb24c81bbcf1927f0de257bae7e038.tar.gz
modules/media: Fix Visual Studio builds with older GLib
The current definitions of the g_io_module_*() symbols do not build on Visual Studio when building against GLib earlier than 2.75.0 due to the way how these symbols are decorated in the GLib headers, as Visual Studio does not allow symbols that were previously marked with 'extern' (or so) to be marked with anything that is symantically different later. As a result, if we are using Visual Studio and glib-2.74.x or earlier, override _GLIB_EXTERN as appropriate in the modules/media sources before including the GIO headers. This sadly, means that we need a configure-time check as it would have been too late if we checked the GLib version using G_VERSION_CHECK macro, as the GIO headers would have been included already. There are similar items in the print backends, but we will not attempt to update these files as they are not meant to be built for Windows.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build7
1 files changed, 7 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 07912b124e..3f05b7b9c6 100644
--- a/meson.build
+++ b/meson.build
@@ -370,6 +370,13 @@ glib_dep = dependency('glib-2.0', version: glib_req)
gobject_dep = dependency('gobject-2.0', version: glib_req)
if os_win32
giowin32_dep = dependency('gio-windows-2.0', version: glib_req, required: win32_enabled)
+ if giowin32_dep.version().version_compare('<2.75.0')
+ if cc.get_id() == 'msvc' and get_option('default_library') != 'static'
+ # Override _GLIB_EXTERN on Visual Studio for media modules for glib <= 2.74.x, so that we
+ # avoid error C2375 (redefinition; different linkage) when building the g_io_module_*() bits
+ cdata.set('MODULES_OVERRIDE_GLIB_EXTERN', true)
+ endif
+ endif
endif
if os_unix
giounix_dep = dependency('gio-unix-2.0', version: glib_req, required: false)