summaryrefslogtreecommitdiff
path: root/gtk/gtkfilechooserdialog.c
Commit message (Collapse)AuthorAgeFilesLines
* filechooserdialog: Add "filechooser" style classAlexander Mikhaylenko2023-04-061-0/+5
|
* gtk: Stop using gtk_widget_show/hideMatthias Clasen2022-11-281-3/+2
| | | | | | | gtk_widget_set_visible and gtk_window_present are better alternatives, and calling gtk_widget_show on newly created widgets is no longer necessary anyway.
* Deprecate GtkDialogMatthias Clasen2022-10-291-1/+1
| | | | | GtkDialog is too flexible in terms of UI (headerbars vs action bar, etc), and has archaic APIs. It is time to retire it.
* Deprecate GtkFileChooser and implementationsMatthias Clasen2022-10-291-2/+8
| | | | | | | | | These are being replaced by GtkFileDialog. This commit only moves the headers for GtkFileChooserWidget and GtkFileChooserDialog to deprecated/, and keeps the implementations in gtk/, since they will eventually be salvaged into a private GtkFileChooserWindow.
* Drop gtkintl.hMatthias Clasen2022-09-241-1/+1
| | | | | Include gtkprivate.h for I_() and glib-i18n.h for gettext macros.
* Rename clear_template to dispose_templateEmmanuele Bassi2022-07-111-1/+1
| | | | | Make it more clear that the function is supposed to be called during the dispose sequence of a widget.
* filechooserdialog: Use gtk_widget_clear_template()Emmanuele Bassi2022-07-111-3/+1
|
* docs: fix broken linksBilal Elmoussaoui2021-05-271-1/+1
|
* docs: Reduce redundancyMatthias Clasen2021-05-201-3/+3
| | | | | | | | Remove a boatload of "or %NULL" from nullable parameters and return values. gi-docgen generates suitable text from the annotation that we don't need to duplicate. This adds a few missing nullable annotations too.
* introspection: Stop using allow-noneMatthias Clasen2021-05-201-3/+3
| | | | | allow-none has been deprecated for a long time already. Instead use optional and nullable everywhere.
* filechooserdialog: Convert docsMatthias Clasen2021-03-111-66/+60
|
* gtk/window: Make 'default-size' adapt to configured sizeJonas Ådahl2020-12-071-1/+1
| | | | | | | | | | | | | | | | | | | | | | This commit changes the behavior of window size computation and the default size properties to: * The default-width and default-height properties are updated to the current window size unless the size is fixed by e.g. being maxmized, tiled etc. * The compute-size semantics are to just pick the default size, or if not adequate, use the measured size, and consequently update the default size, unless unresizable. * gtk_window_get_size() is removed, what's more likely relevant is the gtk_window_get_default_size() which will now contain more sensible values. Various places that used gtk_window_get_size() were updated to use gtk_window_get_default_size() to remember and restore previous sizes. This also changes the default value of 'default-width' and 'default-height' from -1 to 0. The gtk builder simplify tool is taught how to omit when the default size is set to both -1 and 0.
* Remove unneeded gtkstylecontext.h includesTimm Bäder2020-10-141-1/+0
|
* Drop style class definesMatthias Clasen2020-08-141-2/+2
| | | | | | We document the supported style classes by name, not by macro name, and these macros don't really add any value. Drop them for GTK 4.
* filechooser: Document the response.activate actionMatthias Clasen2020-07-281-0/+5
|
* Remove ATKEmmanuele Bassi2020-07-261-2/+0
| | | | | | | | | | | | | | | | | | | | | | | | | | | | | | To build a better world sometimes means having to tear the old one down. -- Alexander Pierce, "Captain America: The Winter Soldier" ATK served us well for nearly 20 years, but the world has changed, and GTK has changed with it. Now ATK is mostly a hindrance towards improving the accessibility stack: - it maps to a very specific implementation, AT-SPI, which is Linux and Unix specific - it requires implementing the same functionality in three different layers of the stack: AT-SPI, ATK, and GTK - only GTK uses it; every other Linux and Unix toolkit and application talks to AT-SPI directly, including assistive technologies Sadly, we cannot incrementally port GTK to a new accessibility stack; since ATK insulates us entirely from the underlying implementation, we cannot replace it piecemeal. Instead, we're going to remove everything and then incrementally build on a clean slate: - add an "accessible" interface, implemented by GTK objects directly, which describe the accessible role and state changes for every UI element - add an "assistive technology context" to proxy a native accessibility API, and assign it to every widget - implement the AT context depending on the platform For more information, see: https://gitlab.gnome.org/GNOME/gtk/-/issues/2833
* Replace "gchar" with "char"Benjamin Otte2020-07-251-5/+5
|
* Replace "gint" with "int"Benjamin Otte2020-07-251-8/+8
|
* filechooserdialog: Stop using ::response-requestedMatthias Clasen2020-07-121-5/+9
| | | | Replace the ::response-requested signal by an action.
* filechooserdialog: Stop using the embed interfaceMatthias Clasen2020-07-121-3/+2
| | | | | | Just call private GtkFileChooserWidget api. There is no real justification for diverting this through an extra interface.
* Reduce includes of gtkfilesystem.hMatthias Clasen2020-07-121-1/+0
| | | | | Move a few non-filesystem helpers to gtkfileutils.h, and drop the include in all the places where it isn't needed.
* filechooser: Drop the ::selection-changed signalMatthias Clasen2020-07-091-23/+0
| | | | | | This signal does not work on native file choosers, and it exposes internals of the widget that should not be public. And it is just not very interesting.
* filechooser: Drop the ::file-activated signalMatthias Clasen2020-07-091-11/+0
| | | | | | This signal does not work on native file choosers, and it exposes internals of the widget that should not be public. And it is just not very interesting.
* filechooser: Make get_files return a list modelMatthias Clasen2020-07-091-3/+3
| | | | | | Like the other list getters in this interface, make gtk_file_chooser_get_files() return a list model.
* docs: Remove use of gtk_dialog_run()Emmanuele Bassi2020-05-121-50/+75
| | | | | Direct people to use GTK_DIALOG_MODAL and the "response" signal instead of nested main loops.
* Replace most remaining uses of container apiMatthias Clasen2020-05-111-2/+2
| | | | These are all on GtkBox or enumerating children.
* Stop using container api on GtkHeaderBarMatthias Clasen2020-05-111-1/+5
|
* Merge branch 'matthiasc/for-master' into 'master'Matthias Clasen2020-05-111-32/+35
|\ | | | | | | | | print-editor: Bring back the menubar See merge request GNOME/gtk!1875
| * filechooserdialog: Be more careful with widgetsMatthias Clasen2020-05-111-32/+35
| | | | | | | | | | | | | | | | | | | | | | | | We were stepping on our own toes, by first setting up a save entry and telling the filechooserwidget about it, and then nuking it by setting a title on the headerbar. The filechooserwidget wasn't ready for the entry to die without anybody telling it. This fixes a crash when using the filechooser for print-to-file in the print dialog.
* | Use gtk_window_destroyMatthias Clasen2020-05-111-2/+2
| | | | | | | | | | Replace calls to gtk_widget_destroy on windows with gtk_window_destroy.
* | filechooserdialog: Fix disposingMatthias Clasen2020-05-111-0/+12
|/ | | | | We need to drop our widgetry in dispose to prevent leakage.
* headerbar: Rename custom-title to title-widgetAlexander Mikhaylenko2020-05-011-3/+3
| | | | | Now that all the other title-related properties are gone, custom title can have a more mundane name.
* filechooserdialog: Create title and subtitle manuallyAlexander Mikhaylenko2020-05-011-1/+47
| | | | | title and subtitle properties will go away in the following commits, stop using them.
* filechooser: Cosmetic doc changesMatthias Clasen2020-04-171-2/+2
|
* Remove GTK_FILE_CHOOSER_ACTION_CREATE_FOLDEREmmanuele Bassi2020-02-221-2/+1
| | | | | We don't need a whole separate action, now that the file chooser widget can create folders; we can create use SELECT_FOLDER and create one.
* Remove overwrite confirmation machinery from GtkFileChooserEmmanuele Bassi2020-02-221-2/+0
| | | | | Overwrite confirmation should not be optional, and it should not loop into application code to create their own dialog and user response.
* Remove filename/URI API from GtkFileChooserEmmanuele Bassi2020-02-221-19/+12
| | | | | | | | | | | | GtkFileChooser's API predates GIO by a few years, so it started off with filenames and URI as character arrays. After introducing GIO as a dependency, the API included GFile-based entry points. It's much more appropriate to use GFile everywhere, as we want to encourage people to use GIO instead of passing random bytes to low level POSIX API. See: #2455
* filechooser: Remove debug spewMatthias Clasen2020-01-311-1/+0
|
* filechooser: Remove default size machineryBenjamin Otte2020-01-281-29/+19
| | | | | | | | | | | The FileChooser ToolKit (fctk) had its own machinery to handle default sizes which was completely busted and trying to marshal random numbers through the widget hierarchy that maybe made sense in 2012 but don't do now. Get rid of it, just keep the dialog's GSetting - which funnily enough used to be written by the dialog but written by the widget. But that's fctk for you.
* filechooserdialog: Stop using gtk_window_get_position()Timm Bäder2019-07-191-7/+2
|
* Revert "file chooser: Stop using gtk_window_get_position"Timm Bäder2019-07-191-0/+32
| | | | | | | This reverts commit 2ed533c3e1f0fe776fb24cc370447a0c63e49f24. This also made the filechooser dialog not save the window size anymore, which does not depend on the gtk_window_get_position() removal.
* file chooser dialog: Drop the priv pointerMatthias Clasen2019-05-281-31/+27
|
* file chooser dialog: Make finalMatthias Clasen2019-05-281-0/+14
|
* Make file chooser saving work againMatthias Clasen2019-05-021-1/+8
| | | | | | | | I was a little overzealous when going for the new default handling here. We can't switch to gtk_widget_activate_default before we actually handle the default.activate action.
* Stop using gtk_widget_grab_defaultMatthias Clasen2019-04-281-1/+1
| | | | Replace gtk_widget_grab_default by gtk_window_set_default_widget.
* file chooser: Stop using gtk_window_activate_defaultMatthias Clasen2019-04-281-25/+2
| | | | | | | | Instead, use the new way of activating default. I think most of the default handling in GtkFileChooserDialog should be dropped, but for now this keeps things working.
* file chooser: Stop using gtk_window_get_positionMatthias Clasen2019-03-261-32/+0
| | | | It is going away.
* widget: Don't pass a position to ->size_allocateTimm Bäder2018-11-131-6/+9
| | | | | The values have been 0/0 for a long time now, so just drop the GtkAllocation argument and replace it with width and height.
* widget: Remove clip from size-allocate vfuncBenjamin Otte2018-04-051-6/+3
| | | | As the clip is no longer needed, get rid of it.
* The big versioning cleanupMatthias Clasen2018-02-061-2/+0
| | | | | | | Remove all the old 2.x and 3.x version annotations. GTK+ 4 is a new start, and from the perspective of a GTK+ 4 developer all these APIs have been around since the beginning.