summaryrefslogtreecommitdiff
path: root/gtk/gtkframe.c
Commit message (Collapse)AuthorAgeFilesLines
* Make widget property setters behaveMatthias Clasen2023-03-301-5/+4
| | | | | | We want to allow setting a property to its current value, while still having a precondition for widget->parent being NULL otherwise.
* Escape GtkBuilder XML tag in comment with backticksunce2023-01-151-2/+2
| | | | | | | | Escape XML tags in gi-docgen oriented comment e.g. from <child> to `<child>`, so that they don't become HTML tag on the final webpage. This fix includes everything from commit ff46ea64 and #5312. Fixes #5312
* Drop gtkintl.hMatthias Clasen2022-09-241-1/+0
| | | | | Include gtkprivate.h for I_() and glib-i18n.h for gettext macros.
* Remove all nicks and blurbs from param specsSophie Herold2022-05-111-12/+4
| | | | | | | | Those property features don't seem to be in use anywhere. They are redundant since the docs cover the same information and more. They also created unnecessary translation work. Closes #4904
* docs: Reduce redundancyMatthias Clasen2021-05-201-2/+1
| | | | | | | | Remove a boatload of "or %NULL" from nullable parameters and return values. gi-docgen generates suitable text from the annotation that we don't need to duplicate. This adds a few missing nullable annotations too.
* introspection: Stop using allow-noneMatthias Clasen2021-05-201-3/+3
| | | | | allow-none has been deprecated for a long time already. Instead use optional and nullable everywhere.
* frame: Use markdown for css treeMatthias Clasen2021-03-111-2/+2
|
* frame: Convert docsMatthias Clasen2021-03-111-61/+86
| | | | | Convert link syntax, add an example image, add property annotations.
* docs: Remove the last few remaining '+' from GTKEmmanuele Bassi2021-03-111-3/+3
|
* Reduce use of GtkStyleContextMatthias Clasen2021-01-281-2/+0
| | | | | | Remove some unnecessary uses of GtkStyleContext where we can directly go to the GtkCssStyle, and and drop unnnecessary includes.
* frame: Remove unnecessary functionTimm Bäder2021-01-031-14/+1
| | | | | Just call the vfunc directly in the only place we used to call the old wrapper
* a11y: Parse reference lists using varargsEmmanuele Bassi2020-11-101-1/+1
| | | | | | | | | | Using GList is a bit lame, and makes the API more complicated to use than necessary in the common case. The only real use case for a GList is gtk_widget_add_mnemonic_label(), and for that we can use the GValue-based API instead. Fixes: #3343
* frame: Set up accessible relationsMatthias Clasen2020-10-211-0/+21
| | | | Mark the child as labelled-by the label.
* gtk: Remove unused header includeBenjamin Otte2020-10-201-1/+0
| | | | | gtkcssnodeprivate.h was mainly used for repositioning CSS nodes in gadgets, and gadgets are gone now.
* frame: Remove need_resize logicTimm Bäder2020-10-141-9/+1
| | | | gtk_widget_set_parent() will queue a resize anyway.
* *: Fix spelling mistakes found by codespellBjörn Daase2020-08-211-1/+1
|
* frame: Set GTK_OVERFLOW_HIDDENnana-42020-08-201-0/+5
| | | | | It doesn't really make sense for the frame to allow drawing children outside of it.
* Remove ATKEmmanuele Bassi2020-07-261-3/+0
| | | | | | | | | | | | | | | | | | | | | | | | | | | | | | To build a better world sometimes means having to tear the old one down. -- Alexander Pierce, "Captain America: The Winter Soldier" ATK served us well for nearly 20 years, but the world has changed, and GTK has changed with it. Now ATK is mostly a hindrance towards improving the accessibility stack: - it maps to a very specific implementation, AT-SPI, which is Linux and Unix specific - it requires implementing the same functionality in three different layers of the stack: AT-SPI, ATK, and GTK - only GTK uses it; every other Linux and Unix toolkit and application talks to AT-SPI directly, including assistive technologies Sadly, we cannot incrementally port GTK to a new accessibility stack; since ATK insulates us entirely from the underlying implementation, we cannot replace it piecemeal. Instead, we're going to remove everything and then incrementally build on a clean slate: - add an "accessible" interface, implemented by GTK objects directly, which describe the accessible role and state changes for every UI element - add an "assistive technology context" to proxy a native accessibility API, and assign it to every widget - implement the AT context depending on the platform For more information, see: https://gitlab.gnome.org/GNOME/gtk/-/issues/2833
* Replace "gfloat" with "float"Benjamin Otte2020-07-251-3/+3
|
* Replace "gchar" with "char"Benjamin Otte2020-07-251-5/+5
|
* Replace "gint" with "int"Benjamin Otte2020-07-251-12/+12
|
* Remove lots of focus vfuncsMatthias Clasen2020-05-111-2/+0
| | | | | In many cases, the default widget vfuncs work just fine, combined with setting focusable.
* frame: Derive from GtkWidgetMatthias Clasen2020-05-041-80/+102
| | | | | | | | We want to remove GtkBin and GtkContainer as they don't provide much useful functionality anymore. This requires us to move get_request_mode and compute_expand down. See #2681
* frame: Add a child propertyMatthias Clasen2020-05-041-37/+91
|
* frame: Fix xalign handlingMatthias Clasen2020-05-041-1/+1
| | | | | | | SEtting a nonzero xalign on frames had no effect, since we were always using the full allocation with here, instead of what the label needs. Found by using testframe for a second.
* frame: Don't queue a resize if xalign changesMatthias Clasen2020-05-041-9/+5
| | | | | | We only need to allocate children in this case. While we touch it, rewrite the setter to modern style.
* Move the idle sizer to GtkWindowMatthias Clasen2020-04-201-1/+0
| | | | | | | | This was only living in gtkcontainer.c for historic reasons. Move it closer to where it belongs, and rename it from 'idle' to 'layout', since it is really about the layout phase of the frame clock, nowadays.
* frame: Drop shadow-typeMatthias Clasen2020-04-171-73/+3
| | | | | Frames that don't draw frames are not very useful, so just drop the shadow-type property.
* Rename gtk_widget{get,set,has}_style_class to _css_classTimm Bäder2020-02-071-2/+2
| | | | We want to use css instead of style everywhere now.
* Start using GtkWidget's new style class APITimm Bäder2020-02-071-4/+2
|
* Remove gtkwidgetpath.h include where no longer neededBenjamin Otte2020-01-281-1/+0
|
* widget: Don't pass a position to ->size_allocateTimm Bäder2018-11-131-12/+14
| | | | | The values have been 0/0 for a long time now, so just drop the GtkAllocation argument and replace it with width and height.
* widget: Allow adding event controllers in ui filesBenjamin Otte2018-04-261-3/+5
|
* frame: Use underscores in widgets ids in the docsTimm Bäder2018-04-151-2/+2
| | | | They will work in composite widget templates this way.
* frame: Remove priv pointerTimm Bäder2018-04-151-32/+24
|
* frame: Stop saving label and child allocationTimm Bäder2018-04-151-14/+9
| | | | We don't use them for anything anymore.
* widget: Remove clip from size-allocate vfuncBenjamin Otte2018-04-051-9/+4
| | | | As the clip is no longer needed, get rid of it.
* Frame: Erase the now-useless property label-yalignDaniel Boles2018-03-121-58/+12
| | | | | | | | | The border is now drawn on the frame node, not using an internal border node, so we are no longer able to align the label to vertically overlap the border. The property no longer performs its original purpose, & nor is it a useful candidate for giving a new role, so no point keeping it. https://bugzilla.gnome.org/show_bug.cgi?id=778886
* Remove some more gtk_widget_get_content_size usesTimm Bäder2017-12-041-1/+2
|
* gtk: Intern css namesMatthias Clasen2017-11-171-1/+1
| | | | This avoids a bunch of strdups at startup.
* Frame: Enhance CSS docsDaniel Boles2017-10-021-4/+8
| | | | | Indicate how the old shadow types are replaced by CSS border-style et al., and quote the names of nodes and classes for easier readability.
* Frame: Add missing fixed-width format to enumsDaniel Boles2017-09-141-2/+2
|
* widget: Add baseline and out_clip parameters to size-allocateTimm Bäder2017-07-191-14/+13
| | | | | | | | | | | Since setting a clip is mandatory for almost all widgets, we can as well change the size-allocate signature to include a out_clip parameter, just like GtkCssGadget did. And since we now always propagate baselines, we might as well pass that one on to size-allocate. This way we can also make sure to transform the clip returned from size-allocate to parent-coordinates, i.e. the same coordinate space priv->allocation is in.
* Replace a few get_content_allocation calls with get_content_sizeTimm Bäder2017-07-191-5/+5
| | | | | The position of the content allocation is almost never relevant since it's 0/0 for measure, size_allocate and snapshot.
* frame: Fix child allocationTimm Bäder2017-07-191-2/+2
| | | | Don't add the parent's allocation from gtk_widget_get_allocation
* frame: Fix copy&paste bug in shadow-type handlingTimm Bäder2017-07-191-2/+2
| | | | | If the given shadow_type is none NONE, we have to remove the .flat style class of course, not add it.
* frame: Remove empty finalize implementationTimm Bäder2017-07-191-11/+0
|
* frame: Remove gadgetTimm Bäder2017-07-191-102/+32
|
* frame: Remove css box drawingTimm Bäder2017-07-191-36/+1
|
* Frame: Don’t advise adding .flat class in codeDaniel Boles2017-05-141-2/+2
| | | | | https://bugzilla.gnome.org/show_bug.cgi?id=779653#c33 and this is closer to what gtk-3-22 says anyway.