summaryrefslogtreecommitdiff
path: root/bootstrap/Makefile.am
diff options
context:
space:
mode:
authorAndy Wingo <wingo@pobox.com>2020-05-08 15:58:23 +0200
committerAndy Wingo <wingo@pobox.com>2020-05-08 16:03:32 +0200
commit220934c49d2629ebf826cc377541694334f44e7e (patch)
treeaf0e30ae74e913a0386709e6ba23cd5cd12f2c1c /bootstrap/Makefile.am
parent116f94d661b61e297b733363b49042c6c14169b4 (diff)
downloadguile-220934c49d2629ebf826cc377541694334f44e7e.tar.gz
Wire up simplified warning levels in "guild compile"
* am/guilec (GUILE_WARNINGS): * am/bootstrap.am (GUILE_WARNINGS): Explictly default to -W1. * bootstrap/Makefile.am (GUILE_WARNINGS): Set to -Wnone, as the meaning of "no -W flags" has changed to be effectively -W1. * module/scripts/compile.scm (%options): Adapt to parse -Wnone, -W2, and so on. (parse-args): Default to (default-warning-level). (show-warning-help): Add more warning help. (compile): Pass #:warning-level.
Diffstat (limited to 'bootstrap/Makefile.am')
-rw-r--r--bootstrap/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/bootstrap/Makefile.am b/bootstrap/Makefile.am
index bcb22cdbc..ddcbfe54a 100644
--- a/bootstrap/Makefile.am
+++ b/bootstrap/Makefile.am
@@ -1,7 +1,7 @@
## Process this file with automake to produce Makefile.in.
##
## Copyright (C) 2009, 2010, 2011, 2012, 2013,
-## 2014, 2015, 2018 Free Software Foundation, Inc.
+## 2014, 2015, 2018, 2020 Free Software Foundation, Inc.
##
## This file is part of GUILE.
##
@@ -21,7 +21,7 @@
## Fifth Floor, Boston, MA 02110-1301 USA
-GUILE_WARNINGS =
+GUILE_WARNINGS = -Wnone
# Loading eval.go happens before boot and therefore before modules are
# resolved. For some reason if compiled without resolve-primitives,
# attempts to resolve primitives at boot fail; weird. Should fix this