summaryrefslogtreecommitdiff
path: root/bootstrap/Makefile.am
diff options
context:
space:
mode:
authorMikael Djurfeldt <mikael@djurfeldt.com>2018-10-25 13:53:47 +0200
committerAndy Wingo <wingo@pobox.com>2019-05-23 17:13:19 +0200
commitaf1d55bcca8005e46212ba89235dfebcd97a12a3 (patch)
tree1b6cd2b393d0cfac69c02b2a73e6a498b7bf97ef /bootstrap/Makefile.am
parent9c10b423a80bd5ec38f6f7af47ee40d3b15e3384 (diff)
downloadguile-af1d55bcca8005e46212ba89235dfebcd97a12a3.tar.gz
Bootstrap optimization
* bootstrap/Makefile.am: Build both eval.go and psyntax-pp.go before the rest of the .go files so that they are handled by a fast macro expander. This saves time for a parallel build.
Diffstat (limited to 'bootstrap/Makefile.am')
-rw-r--r--bootstrap/Makefile.am8
1 files changed, 6 insertions, 2 deletions
diff --git a/bootstrap/Makefile.am b/bootstrap/Makefile.am
index 57b62eb56..bcb22cdbc 100644
--- a/bootstrap/Makefile.am
+++ b/bootstrap/Makefile.am
@@ -32,5 +32,9 @@ GUILE_OPTIMIZATIONS = -O1 -Oresolve-primitives
include $(top_srcdir)/am/bootstrap.am
# We must build the evaluator first, so that we can be sure to control
-# the stack.
-$(filter-out ice-9/eval.go, $(GOBJECTS)): ice-9/eval.go
+# the stack. Then, we build the syntax-case macro expander before the
+# rest, in order to speed up parallel builds.
+ice-9/psyntax-pp.go: | ice-9/eval.go
+
+$(filter-out ice-9/eval.go ice-9/psyntax-pp.go, $(GOBJECTS)): | \
+ ice-9/psyntax-pp.go