summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2013-03-29 18:44:18 +0100
committerLudovic Courtès <ludo@gnu.org>2013-03-29 19:20:01 +0100
commit7e7c6f6a937005b08fffd5aeccdf992459b07137 (patch)
treea1847d8c48d5b601d74a7f5b725c92d372d0653e /configure.ac
parent7bfbd2935fa812a0581df5b78c1a3b9836065f39 (diff)
downloadguile-7e7c6f6a937005b08fffd5aeccdf992459b07137.tar.gz
build: Remove redundant check for `struct timespec'.
* m4/gnulib-cache.m4: Add `time'. * lib/Makefile.am: Update, still from v0.0-7865-ga828bb2. * configure.ac: Remove check for `struct timespec', which was redundant with Gnulib, and conflicted with pthread-win32's <pthread.h>: <http://lists.gnu.org/archive/html/bug-gnulib/2013-03/msg00096.html>.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac18
1 files changed, 0 insertions, 18 deletions
diff --git a/configure.ac b/configure.ac
index 41a55771e..d6d3d497a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1301,24 +1301,6 @@ if test $scm_cv_struct_linger = yes; then
getsockopt and setsockopt system calls.])
fi
-
-# On mingw, struct timespec is in <pthread.h>.
-#
-AC_MSG_CHECKING(for struct timespec)
-AC_CACHE_VAL(scm_cv_struct_timespec,
- AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[
-#include <time.h>
-#if HAVE_PTHREAD_H
-#include <pthread.h>
-#endif]], [[struct timespec t; t.tv_nsec = 100]])],
- [scm_cv_struct_timespec="yes"],
- [scm_cv_struct_timespec="no"]))
-AC_MSG_RESULT($scm_cv_struct_timespec)
-if test $scm_cv_struct_timespec = yes; then
- AC_DEFINE([HAVE_STRUCT_TIMESPEC], 1,
- [Define this if your system defines struct timespec via either <time.h> or <pthread.h>.])
-fi
-
#--------------------------------------------------------------------
#
# Flags for thread support