summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAndy Wingo <wingo@pobox.com>2013-03-09 22:25:35 +0100
committerAndy Wingo <wingo@pobox.com>2013-03-09 22:25:35 +0100
commitcdd125e8d475a6d02606322fb4c54dc76bbc8072 (patch)
tree5cfff088d25214541c6b63c159551fd14683307d /configure.ac
parent4fd38267bca2987c6340c019a498ea6bacc6c5ec (diff)
downloadguile-cdd125e8d475a6d02606322fb4c54dc76bbc8072.tar.gz
portability simplification with scmsigs.c and alarm
* configure.ac (alarm): Check for decl. * libguile/scmsigs.c: Reorder includes to put system includes first. Fixes include order on mingw. Remove #define for alarm, as we will use HAVE_DECL_ALARM. Remove #defines for sleep and usleep, as they are not used. (scm_alarm): Only define if HAVE_DECL_ALARM.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 2 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index d8919d3a9..31cb3a038 100644
--- a/configure.ac
+++ b/configure.ac
@@ -919,6 +919,8 @@ AC_DEFUN([GUILE_FUNC_DECLARED], [
GUILE_FUNC_DECLARED(sleep, unistd.h)
GUILE_FUNC_DECLARED(usleep, unistd.h)
+AC_CHECK_DECLS([alarm])
+
AC_CHECK_DECLS([strptime],,,
[#define _GNU_SOURCE /* ask glibc to give strptime prototype */
#include <time.h>])