summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSergei Trofimovich <slyich@gmail.com>2022-02-20 09:39:59 +0000
committerLudovic Courtès <ludo@gnu.org>2022-03-07 10:54:16 +0100
commitf047133e7b43433e77dc01741d559ac9e2a9ea58 (patch)
tree8d612bc43c2b180fd53f5b07c7e108b29092d668 /configure.ac
parent347321ece9fc85ddf74af3c798230b7b187fbce9 (diff)
downloadguile-f047133e7b43433e77dc01741d559ac9e2a9ea58.tar.gz
build: Test '-flto' on both compiler and linker.
Before the change ./configure incorrectly enabled -flto on toolchains that support -flto on compiler side but don't support -flto on linker side. This caused incorrect type size detection on nixpkgs' Darwin: configure:54594: checking size of size_t configure:54600: clang -std=gnu11 -o conftest -g -O2 -flto conftest.c >&5 ld: warning: ignoring file /private/tmp/nix-build-guile-3.0.8.drv-0/conftest-00e93d.o, building for macOS-x86_64 but attempting to link with file built for unknown-unsupported file format ( 0xDE 0xC0 0x17 0x0B 0x00 0x00 0x00 0x00 0x14 0x00 0x00 0x00 0x80 0x1A 0x00 0x00 ) Undefined symbols for architecture x86_64: "_main", referenced from: implicit entry/start for main executable ld: symbol(s) not found for architecture x86_64 clang-11: error: linker command failed with exit code 1 (use -v to see invocation) Taken from https://github.com/NixOS/nixpkgs/pull/160051#issuecomment-1046105041 The change makes sure -flto support tests basic support of just for object file generation but for linker as well. * configure.ac: use AC_LINK_IFELSE instead of AC_COMPILE_IFELSE. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index ad7ff12c6..30229489d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -69,7 +69,7 @@ AC_MSG_CHECKING([whether the compiler supports -flto])
old_CFLAGS="$CFLAGS"
LTO_CFLAGS="-flto"
CFLAGS="$CFLAGS $LTO_CFLAGS"
-AC_COMPILE_IFELSE([AC_LANG_SOURCE([int foo;])],, [LTO_CFLAGS=])
+AC_LINK_IFELSE([AC_LANG_PROGRAM([int foo;], [])],, [LTO_CFLAGS=])
CFLAGS="$old_CFLAGS"
if test -n "$LTO_CFLAGS"; then
AC_MSG_RESULT([yes])