summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorMarius Vollmer <mvo@zagadka.de>2001-05-05 19:15:52 +0000
committerMarius Vollmer <mvo@zagadka.de>2001-05-05 19:15:52 +0000
commit94a0d8859a92d31bfedcaf257e41f6f6b742d8eb (patch)
treec6a212ffbe5b7f4cc3ddac875cd24aff6af5cdca /configure.in
parenta5eebee787fc4ce4cbcbc2f20fa5df3019bf588f (diff)
downloadguile-94a0d8859a92d31bfedcaf257e41f6f6b742d8eb.tar.gz
(--enable-deprecated): Recognize "shutup" option
argument and turn it into the default warning level "no".
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in8
1 files changed, 6 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index f233c0d91..dbe5bbd28 100644
--- a/configure.in
+++ b/configure.in
@@ -103,9 +103,13 @@ if test "$enable_deprecated" = no; then
AC_DEFINE(SCM_DEBUG_DEPRECATED)
else
if test "$enable_deprecated" = yes || test "$enable_deprecated" = ""; then
- enable_deprecated=summary
+ warn_default=summary
+ elif test "$enable_deprecated" = shutup; then
+ warn_default=no
+ else
+ warn_default=$enable_deprecated
fi
- AC_DEFINE_UNQUOTED(GUILE_WARN_DEPRECATED_DEFAULT, "$enable_deprecated")
+ AC_DEFINE_UNQUOTED(GUILE_WARN_DEPRECATED_DEFAULT, "$warn_default")
fi
dnl The --disable-debug used to control these two. But now they are