summaryrefslogtreecommitdiff
path: root/libguile/Makefile.am
diff options
context:
space:
mode:
authorAndy Wingo <wingo@pobox.com>2021-12-02 13:55:07 +0100
committerAndy Wingo <wingo@pobox.com>2022-01-13 09:37:16 +0100
commitc768115d93cf5535b19770831c142704128c0991 (patch)
tree611d57c9203eb3a1199f2c7bcc2493a8a0b392c9 /libguile/Makefile.am
parent52e310a2ac54fc9c92084b2dacda99918827a765 (diff)
downloadguile-c768115d93cf5535b19770831c142704128c0991.tar.gz
Add new integers.[ch]
The goal is to factor out some fixnum/bignum code here from numbers.[ch]. * libguile/Makefile.am: Add new files. * libguile/integers.c: * libguile/integers.h: New files
Diffstat (limited to 'libguile/Makefile.am')
-rw-r--r--libguile/Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/libguile/Makefile.am b/libguile/Makefile.am
index 3568767af..a06f950de 100644
--- a/libguile/Makefile.am
+++ b/libguile/Makefile.am
@@ -1,6 +1,6 @@
## Process this file with Automake to create Makefile.in
##
-## Copyright (C) 1998-2004, 2006-2014, 2016-2020
+## Copyright (C) 1998-2004, 2006-2014, 2016-2021
## Free Software Foundation, Inc.
##
## This file is part of GUILE.
@@ -174,6 +174,7 @@ libguile_@GUILE_EFFECTIVE_VERSION@_la_SOURCES = \
init.c \
inline.c \
instructions.c \
+ integers.c \
intrinsics.c \
ioext.c \
jit.c \
@@ -528,6 +529,7 @@ uninstall-hook:
## working.
noinst_HEADERS = conv-integer.i.c conv-uinteger.i.c \
elf.h \
+ integers.h \
intrinsics.h \
srfi-14.i.c \
quicksort.i.c \