summaryrefslogtreecommitdiff
path: root/module/Makefile.am
diff options
context:
space:
mode:
authorDaniel Llorens <daniel.llorens@bluewin.ch>2017-02-13 12:58:34 +0100
committerDaniel Llorens <daniel.llorens@bluewin.ch>2017-10-31 13:23:17 +0100
commit3bfd4aaa6e080dc5b33875921b74d733ac16feb2 (patch)
treeb0f041444e146fe32cf1eb47e9204432df805f50 /module/Makefile.am
parentffcdb7bddf9ff7f3b2479bf9ab58090b86bfcf72 (diff)
downloadguile-3bfd4aaa6e080dc5b33875921b74d733ac16feb2.tar.gz
Fix sort, sort! for arrays with nonzero lower bound
* module/ice-9/arrays.scm (array-copy): New function, export. * module/Makefile.am: Install (ice-9 arrays). * doc/ref/api-data.texi: Add documentation for (ice-9 arrays). * libguile/quicksort.i.c: Use signed bounds throughout. * libguile/sort.c (scm_restricted_vector_sort_x): Fix error calls. Fix calls to quicksort. * test-suite/tests/sort.test: Actually test that the sorted results match the original data. Test cases for non-zero base index arrays for sort, sort!, and stable-sort!.
Diffstat (limited to 'module/Makefile.am')
-rw-r--r--module/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/module/Makefile.am b/module/Makefile.am
index d5896bdd8..ec01b456e 100644
--- a/module/Makefile.am
+++ b/module/Makefile.am
@@ -44,6 +44,7 @@ ice-9/psyntax-pp.go: ice-9/psyntax.scm ice-9/psyntax-pp.scm
SOURCES = \
ice-9/and-let-star.scm \
+ ice-9/arrays.scm \
ice-9/atomic.scm \
ice-9/binary-ports.scm \
ice-9/boot-9.scm \