summaryrefslogtreecommitdiff
path: root/module/Makefile.am
diff options
context:
space:
mode:
authorAndy Wingo <wingo@pobox.com>2021-02-13 22:22:33 +0100
committerAndy Wingo <wingo@pobox.com>2021-02-13 22:36:05 +0100
commit40e4e3b2a40bc44bf72a9ae05ea686cbdaf79e05 (patch)
tree4e15e2dfde0a54a5d05a3ced73d192f9fb3bb2c0 /module/Makefile.am
parent7f8149b4de16fba955e2c3bb1ca71e49a62ac95d (diff)
downloadguile-40e4e3b2a40bc44bf72a9ae05ea686cbdaf79e05.tar.gz
Add "read" implementation in Scheme
* module/Makefile.am (SOURCES): Add ice-9/read. * module/ice-9/read.scm: New file. The idea is to move the compiler to use this "read", after proving that it does the same as C. Then we can switch to read-syntax that returns syntax objects with source locations, allowing us to annotate any datum.
Diffstat (limited to 'module/Makefile.am')
-rw-r--r--module/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/module/Makefile.am b/module/Makefile.am
index 86d540148..516fb3a3e 100644
--- a/module/Makefile.am
+++ b/module/Makefile.am
@@ -146,6 +146,7 @@ SOURCES = \
ice-9/q.scm \
ice-9/r5rs.scm \
ice-9/rdelim.scm \
+ ice-9/read.scm \
ice-9/receive.scm \
ice-9/regex.scm \
ice-9/runq.scm \