summaryrefslogtreecommitdiff
path: root/module/Makefile.am
diff options
context:
space:
mode:
authorLinus Björnstam <linus.bjornstam@fastmail.se>2020-03-23 14:59:39 +0100
committerLudovic Courtès <ludo@gnu.org>2020-03-25 22:44:27 +0100
commit5f60eb6bb5af418b332101c69c88da639b117ae4 (patch)
tree421f6fbeb16bc6f098dcd788e30ebf0091d67f20 /module/Makefile.am
parentf8f8986e4a5fad520e0f9e5e150b45178c0a7ed4 (diff)
downloadguile-5f60eb6bb5af418b332101c69c88da639b117ae4.tar.gz
Add SRFI-171 to guile
This adds SRFI-171 (transducers) to guile. The two guile-specific additions are powerful transducers which can be used to generalize transducers like tsegment. They are hard to get right, but powerful and useful enough to warrant inclusion. * doc/ref/srfi-modules.texi: added srfi-171 section * module/Makefile.am (SOURCES): * module/srfi/srfi-171.scm: * module/srfi/srfi-171/meta.scm: Add SRFI-171 * module/srfi/srfi-171/gnu.scm: Add 2 guile-specific extensions. * test-suite/Makefile.am (SCM_TESTS): * test-suite/tests/srfi-171.test: Add tests. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'module/Makefile.am')
-rw-r--r--module/Makefile.am3
1 files changed, 3 insertions, 0 deletions
diff --git a/module/Makefile.am b/module/Makefile.am
index 1d9d524cf..40b4b561a 100644
--- a/module/Makefile.am
+++ b/module/Makefile.am
@@ -312,6 +312,9 @@ SOURCES = \
srfi/srfi-88.scm \
srfi/srfi-98.scm \
srfi/srfi-111.scm \
+ srfi/srfi-171.scm \
+ srfi/srfi-171/gnu.scm \
+ srfi/srfi-171/meta.scm \
\
statprof.scm \
\