summaryrefslogtreecommitdiff
path: root/module/Makefile.am
diff options
context:
space:
mode:
authorAndy Wingo <wingo@pobox.com>2016-11-16 22:37:54 +0100
committerAndy Wingo <wingo@pobox.com>2016-11-16 22:55:45 +0100
commitca74e3fae52dd23f8e8f12194d07041e207f68e7 (patch)
tree8408d8670749d34b4686d93186dd7ec3605a9d64 /module/Makefile.am
parentfcb43488b39db6c2ad15c2dc7f7b53aa492021b4 (diff)
downloadguile-ca74e3fae52dd23f8e8f12194d07041e207f68e7.tar.gz
Add handle-interrupts inst and compiler pass
* libguile/vm-engine.c (vm_engine): Remove initial VM_HANDLE_INTERRUPTS call; surely our caller already handled interrupts. Add handle-interrupts opcode. * am/bootstrap.am (SOURCES): * module/Makefile.am (SOURCES): Add handle-interrupts.scm. * module/system/vm/assembler.scm (system): * module/language/cps/compile-bytecode.scm (compile-function): (lower-cps): Add handle-interrupts support. * module/language/cps/handle-interrupts.scm: New file.
Diffstat (limited to 'module/Makefile.am')
-rw-r--r--module/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/module/Makefile.am b/module/Makefile.am
index 0d1f128f1..67f041d20 100644
--- a/module/Makefile.am
+++ b/module/Makefile.am
@@ -138,6 +138,7 @@ SOURCES = \
language/cps/dce.scm \
language/cps/effects-analysis.scm \
language/cps/elide-values.scm \
+ language/cps/handle-interrupts.scm \
language/cps/intmap.scm \
language/cps/intset.scm \
language/cps/licm.scm \