summaryrefslogtreecommitdiff
path: root/module/Makefile.am
diff options
context:
space:
mode:
authorAndy Wingo <wingo@pobox.com>2021-11-09 15:14:27 +0100
committerAndy Wingo <wingo@pobox.com>2021-11-15 15:32:54 +0100
commitdad113d80f526375c12fe4177427a1936c3939eb (patch)
tree8af908c91ca019e80852c36dda962656f88fdb00 /module/Makefile.am
parent5c76381625e3b5e7b25be0b97b42b487627e6478 (diff)
downloadguile-dad113d80f526375c12fe4177427a1936c3939eb.tar.gz
Add new pass to optimize away return value count checks
* module/language/cps/return-types.scm: New file. * module/Makefile.am (SOURCES): * am/bootstrap.am (SOURCES): Add new file. * module/language/tree-il/compile-cps.scm (sanitize-meta): Strip "noreturn" and "return-type" properties -- these should only be computed by Guile.
Diffstat (limited to 'module/Makefile.am')
-rw-r--r--module/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/module/Makefile.am b/module/Makefile.am
index 303f25e47..f6f5a9bb8 100644
--- a/module/Makefile.am
+++ b/module/Makefile.am
@@ -65,6 +65,7 @@ SOURCES = \
language/cps/prune-top-level-scopes.scm \
language/cps/reify-primitives.scm \
language/cps/renumber.scm \
+ language/cps/return-types.scm \
language/cps/rotate-loops.scm \
language/cps/self-references.scm \
language/cps/simplify.scm \