summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index b3879df1f..f8c12f0d7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1187,6 +1187,9 @@ case "$with_threads" in
pthread_get_stackaddr_np pthread_attr_get_np pthread_sigmask \
pthread_cancel])
+ # Apple Silicon JIT code arena needs to be unprotected before writing.
+ AC_CHECK_FUNCS([pthread_jit_write_protect_np])
+
# On past versions of Solaris, believe 8 through 10 at least, you
# had to write "pthread_once_t foo = { PTHREAD_ONCE_INIT };".
# This is contrary to POSIX: