summaryrefslogtreecommitdiff
path: root/gusb/meson.build
diff options
context:
space:
mode:
authorRichard Hughes <richard@hughsie.com>2022-09-05 20:50:06 +0100
committerRichard Hughes <richard@hughsie.com>2022-09-08 09:06:56 +0100
commit1c778b7013582bab13a66467e12c7573f615cc8c (patch)
tree953159ce969761acb608166d0a5c02bde618882d /gusb/meson.build
parent4eca7b72db7f5c921927ca5b7a16a8d05b093861 (diff)
downloadgusb-1c778b7013582bab13a66467e12c7573f615cc8c.tar.gz
Save device events when required
This allows us to simulate an entire context of devices, simulating responses as if the hardware is connected. This allows building rich device-specific unit tests in programs like fwupd, without having to have the hardware attached.
Diffstat (limited to 'gusb/meson.build')
-rw-r--r--gusb/meson.build6
1 files changed, 6 insertions, 0 deletions
diff --git a/gusb/meson.build b/gusb/meson.build
index eeef369..2b3ad07 100644
--- a/gusb/meson.build
+++ b/gusb/meson.build
@@ -29,6 +29,7 @@ install_headers([
'gusb-context.h',
'gusb-context-private.h',
'gusb-device.h',
+ 'gusb-device-event.h',
'gusb-device-private.h',
'gusb-device-list.h',
'gusb-interface.h',
@@ -55,6 +56,7 @@ gusb = library(
sources : [
'gusb-context.c',
'gusb-device.c',
+ 'gusb-device-event.c',
'gusb-device-list.c',
'gusb-interface.c',
'gusb-bos-descriptor.c',
@@ -111,6 +113,9 @@ libgusb_girtarget = gnome.generate_gir(gusb,
'gusb-context-private.h',
'gusb-device.c',
'gusb-device.h',
+ 'gusb-device-event.c',
+ 'gusb-device-event.h',
+ 'gusb-device-event-private.h',
'gusb-device-list.c',
'gusb-device-list.h',
'gusb-device-private.h',
@@ -200,6 +205,7 @@ if get_option('tests')
sources : [
'gusb-context.c',
'gusb-device.c',
+ 'gusb-device-event.c',
'gusb-device-list.c',
'gusb-interface.c',
'gusb-bos-descriptor.c',