summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 4 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 8bca5d2..89bf1c1 100644
--- a/meson.build
+++ b/meson.build
@@ -116,6 +116,10 @@ gusb_deps = [
libusb,
]
+if not get_option('introspection') and get_option('vapi')
+ error('-Dvapi=true requires -Dintrospection=true')
+endif
+
gnome = import('gnome')
add_project_arguments('-DGUSB_COMPILATION', language: 'c')